Play Store-utvecklare mÄste rikta in sig pÄ sina appar för Android 9 Paj i höst

Google fortsĂ€tter att driva Android-utvecklare att anvĂ€nda de senaste API-funktionerna. I november förra Ă„ret var alla ansökningar som skickats in i butiken skyldiga att rikta in sig pĂ„ Android 8.0 Oreo eller högre – vilket innebĂ€r att de mĂ„ste stödja körtidstillstĂ„nd och andra API-förĂ€ndringar. Som förvĂ€ntat ökar Google nu kraven.

FrĂ„n och med augusti 2019, förmodligen ungefĂ€r nĂ€r Android Q kommer att slĂ€ppas, kommer alla nya appar att behöva inrikta sig pĂ„ Android 9 Pie (API-nivĂ„ 28) eller högre. Med andra ord kan applikationer fortfarande stödja den minsta Android-version de vill ha – till och med att gĂ„ tillbaka till Android 1.0 – men apparna mĂ„ste ocksĂ„ byggas med Android Pie i Ă„tanke. I november mĂ„ste alla appuppdateringar ocksĂ„ vara inriktade pĂ„ Pie. Program som inte uppdateras pĂ„verkas inte.

Google Play Protect börjar ocksÄ varna anvÀndare nÀr de försöker installera förÄldrade appar utanför Play Store. I augusti kommer anvÀndarna att fÄ varningar nÀr de försöker installera en app som inte Àr byggd för Android 8.0 Oreo (API-nivÄ 26) eller högre. I november utvidgas detta till att uppdatera befintliga appar.

Som Google tidigare har angett kommer dessa krav att fortskrida varje Är. Till exempel kommer Google sannolikt att krÀva att appar riktar sig till Android Q frÄn och med augusti 2020.

Försök rulla

0 Shares